
 

 
 

 
 
IT Essentials v4.1 LI 11.4.5 Upgrade and configure storage devices and 
hard drives 

 

CompTIA A+ 220-702 Objective 
2.3 Disk management tools 

 

 
In Windows Vista and Windows 7, use the following path: 
 
Start > Start Search > type diskmgmt.msc > Enter > Continue 

 
IT Essentials v4.1 LI 12.0 Introduction 

 

CompTIA A+ 220-702 Objective 
2.0 Operating Systems 

 

 
Various brands of operating systems are available on the market today, including Microsoft Windows, 
Apple Mac OS, UNIX, and Linux. A technician must consider the current computer system when selecting 
an operating system. Additionally, there are several versions of an operating system. Some versions of 
Microsoft Windows include Windows 2000 Professional, Windows XP Home Edition, Windows XP 
Professional, Windows Media Center, Windows Vista Home Basic, Windows Vista Business, Windows 
Vista Premium, Windows 7 Starter, Windows 7 Home Premium, Windows 7 Professional, and Windows 7 
Ultimate. 

 

IT Essentials v4.1 LI 12.1.3 Windows OS directory structures 
 

CompTIA A+ 220-702 Objective 
2.2 User file locations 
2.2 System file locations 
2.2 Fonts 
2.2 Temporary files 
2.2 Program files 
2.2 Offline files and folders 

 

 
Additions to Figure 1 

Operating 
System 

User Files System 
Files 

Fonts Temporary 
Files 

Program Files Offline 
Files and 

      Folders 
Windows 
7 Starter 

C:/Users/U 
ser_name 

C:/Wind 
ows/Sys 
tem32 

C:/Windo 
ws/Fonts 

C:\Users\U 
ser_name\ 
AppData\L 
ocal\Temp 

C:\Program Files Not 
supported 

Windows 
7 Home 
Premium 

C:/Users/U 
ser_name 

C:/Wind 
ows/Sys 
tem32 

C:/Windo 
ws/Fonts 

C:\Users\U 
ser_name\ 
AppData\L 
ocal\Temp 

C:\Program Files for 
64-bit 
C:\Program Files (x86) 
for 32-bit 

Not 
supported 

Windows 
7 
Professio 
nal 

C:/Users/U 
ser_name 

C:/Wind 
ows/Sys 
tem32 

C:/Windo 
ws/Fonts 

C:\Users\U 
ser_name\ 
AppData\L 
ocal\Temp 

C:\Program Files for 
64-bit 
C:\Program Files (x86) 
for 32-bit 

C:\Windows\ 
CSC 



Windows 
7 Ultimate 

C:/Users/U 
ser_name 

C:/Wind 
ows/Sys 
tem32 

C:/Windo 
ws/Fonts 

C:\Users\U 
ser_name\ 
AppData\L 
ocal\Temp 

C:\Program Files for 
64-bit 
C:\Program Files (x86) 
for 32-bit 

C:\Windows\ 
CSC 

 

 

IT Essentials v4.1 LI 12.2.3 Create, view, and manage disks, directories, and 
files 
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2.3 Disk management tools 
2.3 FAT32, NTFS, FAT64 (exFAT) 

 
Within the operating system, disks and directories are locations where data is stored and organized. The 
file system used by the operating system determines additional factors that affect storage such as 
partition size, cluster size, and security features. 

 
Disk Structure 

A hard disk is divided into specific areas called partitions. Partitions are formatted so that they can store 
information. The Disk Management utility displays information and performs services such as partitioning 
and formatting disks in Windows. Figure 1 shows the Disk Management utility used in Windows XP. 

 
There are several types of partitions on a hard drive: 

 
• Primary partition – This is usually the first partition. A primary partition cannot be subdivided into 

smaller sections. There can be up to four partitions per hard drive. 

• Active partition – This partition is used by the operating system to boot the computer. Only one 

primary partition can be marked active. 

• Extended partition – This partition normally uses the remaining free space on a hard drive or 

takes the place of a primary partition. There can be only one extended partition per hard drive, 
and it can be subdivided into smaller sections called logical drives. 

 
NOTE: At any given time, you can only designate one partition as the active partition. The operating 

system uses the active partition to boot up the system. The active partition must be a primary partition. 

 
In most cases, the C: drive is the active partition and contains the boot and system files. Some users 
create additional partitions to organize files or to be able to dual-boot the computer. 

 
There are several ways to access the Disk Management utility in Windows XP: 

 

• Select Start > right-click My Computer > Manage. 

• Select Disk Management. 

• Select Start > Settings > Control Panel > Administrative Tools > Computer Management. 

• Select Disk Management. 

 
There are several ways to access the Disk Management utility in Windows Vista: 

 
• Select Start > right-click My Computer > Manage. 

• Select Disk Management. 

• Select Start > Settings > Control Panel > Administrative Tools > Computer Management > 
Continue. 

• Select Disk Management. 

 
There are several ways to access the Disk Management utility in Windows 7: 

 
• Select Start > right-click My Computer > Manage. 

• Select Disk Management. 

• Select Start > Control Panel > System and Security > Administrative Tools > Computer 
Management 

• Select Disk Management. 
 
 



 
 
 
 
In Windows, letters are used to name the drives. A Windows computer can have up to 26 physical and 
logical drives, because there are 26 letters in the English alphabet. Drives A and B are reserved for floppy 
disk drives, and drive C is reserved for the primary, active partition. Therefore, the maximum number of 
additional drives is 23. In Windows Vista and Windows 7, you can assign drives A and B to volumes if you 
do not have floppy drives. 

 
With the NTFS file system, a drive can be mapped to an empty folder on a volume and is referred to as a 
mounted drive. Mounted drives are assigned drive paths instead of letters and are displayed as a drive 
icon in Windows Explorer. Use a mounted drive to configure more than 26 drives on your computer or 
when you need additional storage space on a volume. 

 
To mount a volume in Windows: 

 
• Open Computer Management and select Disk Management. 

• Right-click the partition or volume to be mounted. 

• Click Change Drive Letter and Paths. 

• Click Add. 

• Click Mount in the following empty NTFS folder. 

• Create an empty folder, type the path to an empty folder, or browse to an empty folder on an 
NTFS volume and click OK. 

• Close Computer Management. 

 
Drive Status 

The Disk Management utility displays the status of each disk, as shown in Figure 2. The hard drives in the 
computer will display one of the following conditions: 

 
• Foreign – A dynamic disk that has been moved to a computer from another computer running 

Windows 2000 or Windows XP 

• Healthy – A volume that is functioning properly 

• Initializing – A basic disk that is being converted into a dynamic disk 

• Missing – A dynamic disk that is corrupted, turned off, or disconnected 

• Not Initialized – A disk that does not contain a valid signature 

• Online – A basic or dynamic disk that is accessible and shows no problems 

• Online (Errors) – I/O errors that are detected on a dynamic disk 

• Offline – A dynamic disk that is corrupted or unavailable 

• Unreadable – A basic or dynamic disk that has experienced hardware failure, corruption, or I/O 

errors 

 
Other drive status indicators might be displayed when using drives other than hard drives: 

 
• Audio CD – An audio CD that is in the optical drive 

• No Media – An optical or removable drive that is empty 

 
File System 
Partitions are formatted with a file system. The three file systems available in Windows XP are FAT 
(FAT16), FAT32, and NTFS. NTFS has greater stability and security features. FAT32, NTFS, and exFAT 
are compared in Figure 3. exFAT, or FAT64, was created to address some of the limitations of using FAT, 
FAT32, or NTFS when formatting USB flash drives, such as file size and directory size. 

 
For example, Windows does not display the file extension, but this practice can cause security problems. 
Virus writers are able to distribute executable files disguised as a non-executable file. To avoid this 
security breach, you should always show file extensions by doing the following: 

 
Select Start > Control Panel > Folder Options > View, and uncheck the Hide extensions for known 
file types check box, as shown in Figure 4. 

 
 
 



 
 
 
In Windows Vista and Windows 7, click Start > Control Panel > Appearance and Personalization > 
Folder Options > View, and uncheck the Hide extensions for known file types check box. 

 
NOTE: Saving files to the root directory of the C: drive can cause organizational problems with data. It is 

a best practice to store data in folders created on the C: drive. 
 

Additions to Figure 3 

 exFAT 
Security exFAT can support access control lists (ACLs) that define permissions for user 

access 
Compatibility Compatible with Windows XP with SP2 or SP3, Windows Vista with SP1, Windows 

7, Windows Server 2003 with SP2, Windows Server 2008, and Linux 
File Size Theoretical maximum of 64 zettabytes (ZBs), 512 TB recommended 
Files Per Volume Maximum of 16 exabytes (EBs) 
File Size Efficiency Cluster size up to 32 MB 
Reliability Can track changes to the file system and recover data if TFAT (Transaction-Safe 

FAT File System) is enabled. TFAT retains two copies of the file system. If one 
table is lost or corrupted, the other copy is recoverable 

 

 

IT Essentials v4.1 LI 12.2.4 Identify procedures and utilities used to 
optimize the performance of operating systems 
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2.3 DEFRAG 
2.3 Check Disk 
2.3 System monitor 
2.3 Resource usage 

 

 
Several procedures and tools are available to optimize the performance of an operating system. The 
concepts may be the same across operating systems, but the optimization methods and procedures are 
different. For example, while virtual memory performs the same function on a Windows 98 and Windows 
XP operating system, the path to find and set virtual memory settings is different. 

 
System Tools 
To maintain and optimize an operating system, you can access various tools within Windows. Some of 
these tools include disk error checking, which can scan the hard drive for file structure errors, and hard 
drive defragmentation, which can consolidate files for faster access. Figure 1 shows the hard drive 
management tools. 

 
Disk Error-Checking Tool 

The Windows operating system uses CHKDSK from within the GUI or at the command line to detect and 
repair disk errors. 

 
To check a drive for errors using the GUI, follow these steps: 

 
1.   In Windows XP, double-click My Computer. In Windows Vista or Windows 7, click Computer in 

the Start menu. 
2.   Right-click the drive that you want to check. 
3.   Click Properties. 
4.   On the Tools tab, under Error-checking, click Check Now. 
5.   Under Check disk options, select the Scan for and attempt recovery of bad sectors check box. 
6.   Click Start. 

 
NOTE: The Scan for and attempt recovery of bad sectors option will automatically fix file system 
errors as well as check the disk for bad sectors and recover any data from sectors that are found to be 
bad. Any data that is recovered is saved to files in the root directory of the disk. 

 
The CLI version of the utility has four options to check a drive for errors: 



 
• chkdsk – Displays a status report of the drive 

• chkdsk /f – Fixes errors on the disk 

• chkdsk /r – Recovers readable information from bad sectors 

• chkdsk /x – Dismounts the volume if necessary 

 
CHKDSK makes multiple passes over the disk, checking for specific criteria: 

 
• Phase 1: Checking Files – CHKDSK examines each file record in the Master File Table (MFT) 

for consistency. By the end of this phase, used and available space on the volume have been 
identified. 

• Phase 2: Checking Indexes – CHKDSK examines the MFT to ensure that every file and 

directory is referenced by at least one entry. Finally, CHKDSK checks that the time stamps and 
file sizes are correct in the directory listings. 

• Phase 3: Checking Security Descriptors – CHKDSK examines the security descriptors for file 
or directory ownership information and NTFS permissions. 

• Phases 4 and 5: Checking Sectors – If the /r option is used, CHKDSK makes two more passes 
looking for sectors that have physical damage. 

 
Disk Defragmenter 

To help optimize the files on the hard drive, Windows operating systems provide a defragmentation utility. 
As files are accessed and stored on a hard drive, the files change from being contiguous on the disk to 
being scattered across the disk. This can cause the operating system to slow down. The hard drive has to 
search several areas on the hard drive platter to find the entire file. For one file, the effect of the process 
is minimal. When this occurs for thousands of files, however, the process will physically slow down the 
reading and writing of a file to a hard drive. 

 
To defragment a drive in Windows XP, double-click My Computer on the desktop. Right-click the drive 
that you want to optimize. Choose Properties. On the Tools tab, click Defragment Now. 

 
To defragment a drive in Windows Vista, double-click Computer on the desktop. Right-click the drive that 
you want to optimize. Choose Properties. On the Tools tab, click Defragment Now. 

 
To defragment a drive in Windows 7, click Computer in the Start Menu. Right-click the drive that you 
want to optimize. Choose Properties. On the Tools tab, click Defragment Now. 

 
System Information 

Administrators can use the System Information tool, as shown in Figure 2, to collect and display 
information about local and remote computers. The System Information tool quickly finds information 
about software, drivers, hardware configurations, and computer components. The information can 
be used by support personnel to diagnose and troubleshoot a computer. 

 
To access the System Information tool, use the following path in the Start Menu: 

 
All Programs > Accessories > System Tools > System Information 

 
It may be necessary to send a file containing all of the information about a computer to another technician 
or help desk. To export a System Information file, click File > Export, type the name of the file, choose a 
location, and click Save. 

 
The System Information tool in Windows XP also provides quick access to many other tools: 

 
• Net Diagnostics – This tool runs a variety of network tests to troubleshoot network-related 

problems. 

• System Restore – This tool creates or loads a restore point for restoring the computer’s system 
files and settings. 

• File Signature Verification Utility – This tool checks for system files that are not digitally signed. 

• DirectX Diagnostic Tool – This tool reports detailed information about the DirectX components 
that are installed on your computer. 

• Dr Watson – This tool debugs Windows to help diagnose program errors. 

To view the information from a remote computer, follow these steps: 



• Choose View > Remote Computer. 

• Choose Remote Computer on the Network. 

• Type the name of the computer that you want to view and click OK. 

 
Remote Desktop Protocol 
The Remote Desktop Protocol allows you to use an application such as Remote Desktop or Remote 
Assistance to connect to another computer. These applications allow you to view the screen and control 
the computer’s mouse and keyboard as though you were local to that computer. The Remote Desktop 
Protocol is also used to operate computers that are connected to the network but do not have a monitor, 
mouse, or keyboard. 

 
To access the Remote Desktop program, use the following path: 

 
All Programs > Accessories > Remote Desktop Connection 

 

 
 

Remote Assistance uses the Remote Desktop Protocol to allow another user to connect to your 
computer, see your computer screen, and chat over a network. With your permission, the remote user 
can control your computer. 

 
To access the Remote Assistance program in Windows XP, use the following path: 

 
Start > Help and Support > Invite a friend to connect to your computer with Remote Assistance > 
Invite someone to help you 

 
In Windows Vista, use the following path: 

 
Start > Help and Support > Use Windows Remote Assistance to get help from a friend or offer help 
> Invite someone you trust to help you 

 
In Windows 7, use the following path: 

 
Start > Help and Support > More support options > Windows Remote Assistance > Invite someone 
you trust to help you 

 
An e-mail invitation must be sent to another user to allow them to connect and control your computer. 
After the recipient has received the invitation, the recipient can see your desktop and help you. 

 
Virtual Memory 

Virtual memory, shown in Figure 3, allows the CPU to address more memory than is installed in the 
computer. This is done so that every application can address the same amount of memory. Virtual 
memory is a swap or page file that is constantly read in and out of RAM. Typically, you should let 
Windows manage the size of the swap file. The only setting that you should change is the location of the 
swap file. You must be a member of the administrator group to make this change. 

 
To access virtual memory settings in Windows XP, use the following path: 

 
Start > Control Panel > System > Advanced tab > Performance, click the Settings button > 
Advanced tab 

 
To access virtual memory settings in Windows Vista, use the following path: 

 
Start > Control Panel > System > Advanced system settings > Continue > Advanced tab > 
Performance, click the Settings button > Advanced tab 

 
To access virtual memory settings in Windows 7, use the following path: 

 
Start > Control Panel > System and Security > System > Advanced system settings > Advanced 
tab > Performance, click the Settings button > Advanced tab 

 
 
 



 
 
 
Administrative Tools 

Windows contains many tools that are used to manage permissions and users or configure computer 
components and services. You must possess administrator rights to access administrative tools. These 
are some of the most common administrative tools: 

 
1.   Event Viewer – This tool logs a history of events regarding applications, security, and the 

system. 
2.   Computer Management – This tool allows you to access administrative areas such as System 

Tools, Storage, and Services and Applications. 

3.   Services – This tool allows you to manage all of the services on local and remote computers. 
4.   Performance Monitor – This tool displays and logs real-time information about the processors, 

disks, memory, and network usage for the computer. 

 
Services 

Services are a type of application that runs in the background to achieve a specific goal or wait for a 
request. Only necessary services should be started to reduce unnecessary security risks. See Figure 4 
for some of the services available on a computer. Four settings, or states, can be used to control the 
services: 

 
• Automatic 

• Manual 

• Disabled 

• Stopped 

 
If a service, such as DHCP or Automatic Updates, is set to automatic, it will start up when the PC starts. 
Manual services, such as the support of an UPS, need to be manually configured to work. Some services 
may be stopped or disabled for troubleshooting purposes, such as turning off the print spooler when there 
are printer problems. 

 
Device Manager 

The Device Manager, shown in Figure 5, allows you to view all of the settings for devices in a computer 
such as the IRQ, I/O address, and the DMA settings. It can also be used to diagnose and resolve device 
conflicts. From the Device Manager, you can view details about the installed driver version. You can also 
perform the following functions: 

 
• Update a driver 

• Roll back a driver 

• Uninstall a driver 

• Disable a device 

 
The Device Manager uses special icons to indicate a problem with a specific device: 

 
• A red X appears on the icon of devices that have been disabled. 

• An exclamation point inside a yellow triangle appears on the icon of devices that do not have 
properly installed drivers or do not respond. 

 
Task Manager 

The Task Manager, shown in Figure 6, allows you to view information about applications that are 
currently running. From the Task Manager, you can perform many functions: 

 
• Close any applications that have stopped responding. 

• Start a new task. 

• Monitor the performance of the CPU. 

• Monitor the performance of the virtual memory. 

• View all processes that are currently running. 

• View information about network connections. 

There are five tabs within the Task Manager: 



• Applications – This tab shows all of the applications that are running. From this tab, you can 

create, switch to, or end tasks using the buttons at the bottom of this tab. 

• Processes – This tab shows all of the processes that are running. A process is any set of 
instructions running on the computer that were started by a user, a program, or the operating 
system. From this tab, you can end processes or set process priorities. 

• Performance – This tab shows the CPU and page file usage of the computer. 

• Networking – This tab shows the usage of all network adapters in the computer. 

• Users – This tab shows all users that are logged on the computer. From this tab, you can 
disconnect remote users or log off local users. 

 
Windows 7 has an additional tab called Services, which displays all the installed services and their status, 
and from which you can start and stop services. 

 
Be careful when ending processes. Ending a process will cause the program to end immediately without 
saving any information. Ending a process that Windows has initiated may prevent the system from 
running correctly. Be careful when changing the priority of processes. If you change the priority of a 
process, the change might adversely affect the performance of the computer. 

 
System Monitor 
The System Monitor in Windows XP, shown in Figure 7, is part of the Performance Console and displays 
real-time information about the processors, disks, memory, and network usage of the computer. You can 
easily summarize these activities through histograms, graphs, and reports. In Windows Vista and 
Windows 7, Performance Monitor is used to collect real-time information. 

 
You must have administrative privileges to access the Performance Monitor console. To view the 
Performance Monitor console in Windows XP, use the following path: 

 
Start > Control Panel > Administrative Tools > Performance 

 
To view the Performance Monitor console in Windows Vista, use the following path: 

 
Start > Control Panel > Administrative Tools > Reliability and Performance Monitor > Continue 

 
To view the Performance Monitor console in Windows 7, use the following path: 

 
Start > Control Panel > System and Security > Administrative Tools > Performance Monitor > 
Performance Monitor 

 
The data that the System Monitor displays is used to help you understand how the workload of the 
computer affects system resources such as the CPU, memory, and network. Use the System Monitor to 
display detailed data about the resources that you are using when performing specific tasks or multiple 
tasks. The data that you collect helps you to determine when an upgrade might be necessary. The 
System Monitor shows how configuration changes or system tuning affects the computer. For example, 
use the System Monitor to determine whether a newly installed program needs more RAM in the 
computer. 

 
Regional and Language Options 

You can change many of the standards and formats for numbers, currencies, dates, and time by using 
the Regional and Language Options settings. These settings also allow you to change the primary 
language or install an additional language. To access the Regional and Language Options settings in 
Windows XP, use the following path: 

 
Start > Control Panel > Regional and Language Options 

 
 
 
 
 



 

 
In Windows Vista and Windows 7, access the Regional and Language Options settings, using the 
following path: 

 
Start > Control Panel > Clock, Language, and Region > Region and Language 

 
Temporary Files 

Almost every program uses temporary files, which are usually automatically deleted when the application 
or the operating system is finished using them. However, some of the temporary files must be deleted 
manually. Since temporary files take up hard drive space that could be used for other files, it is a good 
idea to check and delete as necessary every two or three months. Temporary files are usually located in 
the following locations in Windows XP: 

 
• C:\Temp 

• C:\Tmp 

• C:\Windows\Temp 

• C:\Windows\Tmp 

• C:\Documents and Settings\%USERPROFILE%\Local Settings\Temp 

 
Temporary files are usually located in the following locations in Windows Vista and Windows 7: 

 
• C:\Windows\Temp 

• C:\Users\%USERPROFILE%\AppData\Local\Temp 

 
NOTE: In the paths above, %USERPROFILE% is an environment variable set by the operating system 
with the name of the user that is currently logged on to the computer. Environment variables are used by 
the operating system, applications, and software installation programs. To see the environment variables 
that are configured on your Windows XP computer, use the following path: 

 
Start > Control Panel > System > Advanced > Environment Variables 

 
To see the environment variables that are configured on your Windows Vista, use the following path: 

 
Start > Control Panel > System > Advance system settings > Advanced tab > Environmental 
Variables 

 
To see the environment variables that are configured on your Windows 7 computer, use the following 
path: 

 
Start > Control Panel > System and Security > System > Advanced System Settings > Advanced 
tab > Environment Variables 
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3.2 Install and configure a small office home office (SOHO) network 

 

 
To access the cache settings in Windows Vista or Windows 7, open an IE browser window and choose 
Tools > Internet Options. In the Browsing History area, click Settings. 
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2.1 SFC 

 
NOTE: To run the SFC program in Windows Vista and Windows 7, you must first open a console with 

administrator privileges using the following path: 

 
Start > All Programs > Accessories > right-click Command Prompt > Run as administrator > Yes 
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2.0 Operating Systems 

 

 
• Only Windows Vista can be upgraded to Windows 7. 
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2.3 Task Scheduler 

 

 
To open the Scheduled Tasks wizard in Windows Vista or Windows 7, select Start > All Programs > 
Accessories > System Tools > Task Scheduler. Select Create Basic Task or Create Task, as shown 
in Figure 2. 

 

IT Essentials v4.1 LI 12.5.2 Identify common problems and solutions 
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2.4 Devices drivers failure (input / output devices) 
2.4 Application install, start or load failure 
2.4 Device / service failed to start 
2.4 Device / program in registry not found 
2.4 System Performance and Optimization, Aero settings, UAC 

 
 

The auto restart function can be disabled in the Advanced Startup Options menu. Figures 1, 2, and 3 are 
charts of common operating system problems and solutions. 

 
New Figure 3 

 

Common Windows 7 Problems and Solutions 
 



 
 

Older programs 
are not compatible 
with Windows 7. 

The programs were 
installed before 
upgrading to 
Windows 7. 

Reinstall the programs in 
Compatibility Mode. 

A device is not 
detected, installed, 
or working 
properly. 

A driver is not 
compatible with 
Windows 7. 

Update the driver to a Windows 7 
driver. 

The DVD drive is 
not found after 
upgrading to 
Windows 7. 

A registry error 
prevents Windows 
7 from recognizing 
the DVD drive. 

Open the Windows registry and 
navigate to 
HKEY_LOCAL_MACHINE\SYSTEM\ 
CurrentControlSet\Control\Class\{4D3 
6E965-E325-11CE-BFC1- 
08002BE10318}. 

 

Delete the UpperFilters and 
LowerFilters registry keys. 

Restart the computer. 

The Aero theme 
does not work. 

The graphics card 
does not support 
Aero. 

 

The graphics card 
driver is not up to 
date. 

Replace the graphics card with one 
that meets the minimum hardware 
requirements for Windows 7. 

 

Update the driver for the graphics 
card. 

Windows 7 runs 
slowly. 

Unnecessary visual 
effects are slowing 
down the GUI. 

In the Performance Information and 
Tools control panel, select Adjust for 
best performance in the 
Performance Options dialog box. 

Windows 7 UAC 
appears too often. 

The UAC setting is 
too high for basic 
computing. 

Lower the UAC setting in the Change 
User Account Control settings 
dialog box of the User Accounts 
control. 

 

 

 

 
 


