
 

 

 
 
 
 

NOTE: 

 
• Although there are many versions of Windows 7, for the purpose of this document, the focus is on 

Windows 7 Starter, Windows 7 Home Premium, Windows 7 Professional, and Windows 7 Ultimate. 

• In this document, we refer to The Start Button as Start. 

• In this document, we refer to the Windows 7 Search Programs and Files as Start Search. 

• In Windows Vista and Windows 7, My Computer is called Computer. 

 

IT Essentials v4.1 LI 5.1.2 Explain operating system concepts 
 

CompTIA A+ 220-701 Objective 
3.1 Application compatibility, installed program locations (32 bit versus 64 bit), Windows compatibility mode 

 
In Windows 7, you can adjust the level of monitoring that the UAC performs, as shown in Figure 3. When 
Windows 7 is installed, the primary account is set to Default – Notify me only when programs try to 
make changes to my computer. To adjust the level of UAC monitoring, use the following path: 

 
Start > Control Panel > User Accounts and Family Safety > User Accounts > Change User Account 
Control settings 

 
NOTE: The Control Panel in Windows 7 has three view options: Category, Large icons and Small icons. 

This course uses the Category view. 
 

Like Windows Vista, some older programs might run incorrectly or not at all, even when using Windows 
compatibility mode. To fix the problem, you can change the compatibility settings for the program either 
manually or by using the Program Compatibility troubleshooter. 

 
To troubleshoot program compatibility in Windows 7, follow these steps: 

 
1.   Click Start > Control Panel. 
2.   In the search box, type troubleshooter and click Troubleshooting in the list displayed. 
3.   Under Programs, click Run programs made for previous versions of Windows, and click 

Next. 

Windows searches for compatibility issues, and a list of programs is displayed. 
4.   Select the program you are having problems with and click Next. If the program is not listed, 

select Not listed > Next > Browse to locate the program, and then click Open > Next. 
5.   You can choose Try recommended settings to run the program using the settings that Windows 

7 has determined to be the most compatible, or you can also choose Troubleshoot program, 

which allows you to select troubleshooting steps based on the problems that you noticed. 
6.   Click Start the Program to see if the problem is solved. 
7.   Click Next for Windows to apply the settings permanently, or repeat the process to choose 

different settings until compatibility is reached. 
 

You can also run the Program Compatibility troubleshooter by right-clicking the program’s shortcut or icon 
and then choose Troubleshoot compatibility. 

 

New Figure 3 
 

User Account Control Settings 
 
 
 
 
 

 



 

 
 

 
 

 
 

IT Essentials v4.1 LI 5.2.1 Describe desktop operating systems 
 

CompTIA A+ 220-701 Objective 
3.1 Compare and contrast the different Windows Operating Systems and their features 

 
• Windows 7 Starter – Used on netbook computers to make networking easy 

• Windows 7 Home Premium – Used on home computers to easily share media 

• Windows 7 Professional – Used on work computers to secure critical information and to make 
routine tasks easier to complete 

• Windows 7 Ultimate – Used on computers to combine the ease of use of Windows 7 Home 

Premium with the business capabilities of Windows 7 Professional and provide added data 
security 

 

IT Essentials v4.1 LI 5.3.2 Determine minimum hardware requirements and 
compatibility with the OS platform 

 

CompTIA A+ 220-701 Objective 
3.1 Compare and contrast the different Windows Operating Systems and their features 

 

Additions to Figure 1 

 CPU RAM Hard 
Disk 
Drive 

Video 
Adapter 
Card 

Features Ideal Use 
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Windows 7 
Starter 

1 GHz or 
faster 32-bit 
(x86) or 64- 
bit (x64) 
processor 

1 GB 
RAM 

Hard 
drive with 
at least 
16 GB of 
available 
space 
(32-bit) 

DirectX 9 
graphics 
device 
with 
WDDM 
1.0 or later 
driver 

• Jump Lists 

• Pin 

• Snap 

• Windows 
Search 

Good choice for 
consumers with 
a netbook 

Windows 7 
Home 
Premium 

1 GHz or 
faster 32-bit 
(x86) or 64- 
bit (x64) 
processor 

1 GB 
RAM 
(32-bit) 
or 2 GB 
RAM 
(64-bit) 

Hard 
drive with 
at least 
16 GB of 
available 
space 
(32-bit) 
or 20 GB 
(64-bit) 

DirectX 9 
graphics 
device 
with 
WDDM 
1.0 or later 
driver 

• Shake 

• Customizable 
themes 

• Improved 
Desktop 
Navigation 

• Internet TV 

• HomeGroup 

Good choice for 
home users 
who want to 
share media 

Windows 7 
Professional 

1 GHz or 
faster 32-bit 
(x86) or 64- 
bit (x64) 
processor 

1 GB 
RAM 
(32-bit) 
or 2 GB 
RAM 
(64-bit) 

Hard 
drive with 
at least 
16 GB of 
available 
space 
(32-bit) 
or 20 GB 
(64-bit) 

DirectX 9 
graphics 
device 
with 
WDDM 
1.0 or later 
driver 

• Location 
aware printing 

• Windows XP 
Mode 

• Domain Join 

• Backups to 

home or 
business 
network 

Good choice for 
people who use 
business 
applications 
and want to 
secure data 

Windows 7 
Ultimate 

1 GHz or 
faster 32-bit 
(x86) or 64- 
bit (x64) 
processor 

1 GB 
RAM 
(32-bit) 
or 2 GB 
RAM 
(64-bit) 

Hard 
drive with 
at least 
16 GB of 
available 
space 
(32-bit) 

or 20 GB 
(64-bit) 

DirectX 9 
graphics 
device 
with 
WDDM 
1.0 or later 
driver 

• BitLocker 

• Switch 
between any 
of 35 
languages 

Good choice for 
people who 
need security, 
share media, 
and run 
multiple 
business 
applications 

 

Additions to Figure 2 

 32-bit 64-bit Operating 
System Path 

Installed Programs 
Path 

Windows 7 
Starter 

X  C:\Windows C:\Program Files 

Windows 7 
Home Premium 

X X C:\Windows C:\Program Files for 64- 
bit applications 
C:\Program Files (x86) 
for 32-bit applications 

Windows 7 
Professional 

X X C:\Windows C:\Program Files for 64- 
bit applications 
C:\Program Files (x86) 
for 32-bit applications 

Windows 7 
Ultimate 

X X C:\Windows C:\Program Files for 64- 
bit applications 
C:\Program Files (x86) 
for 32-bit applications 

 

 

 

 

 



 

IT Essentials v4.1 LI 5.4.2 Prepare hard drive 
 

CompTIA A+ 220-701 Objective 
 

3.3 Disk preparation order, Format drive, Partition 

 
The Windows Vista and Windows 7 operating systems automatically create a partition using the entire 
hard drive. If you do not create custom partitions using the New option, as shown in Figure 2, the system 
formats the partition and begins installing Windows. If you create and format your own partitions, the 
process is the same as Windows XP, except that Windows Vista and Windows 7 do not provide a choice 
of file systems. The partition is formatted with NTFS. 

 

IT Essentials v4.1 LI 5.4.3 Install the operating system using default 
settings 

 

CompTIA A+ 220-701 Objective 
3.3 Repair install 

 
 

When a computer boots using the Windows Vista or Windows 7 installation disc, three options are 
available: 

 
• Upgrade – Upgrades Windows but keeps your current files, settings, and programs. Use this 

option to repair an installation. 

• Custom (advanced) – Installs a clean copy of Windows in your choice of location and allows you 
to change disks and partitions. 

• Quit – Exits Setup. 

If existing Windows installations are not found, the Upgrade option is disabled, as shown in Figure 2. 

Unless you perform a clean installation of Windows 7, the previous Windows folder is kept, along with the 
Documents and Settings and Program Files folders. During the Windows 7 installation, these folders are 
moved to a folder named Windows.old. You can copy files from previous installations to your new 
installation if you need them. 

 

IT Essentials v4.1 LI 5.4.5 Complete the installation 
 

CompTIA A+ 220-701 Objective 
2.5 OS 

 
Windows 7 Changes: Add Windows 7 to the instructions for accessing Windows Update. 

 
In Windows Vista or Windows 7, use the following path to access Windows Update: 

 
Start > All Programs > Windows Update 

 
Windows 7 Changes: Add Windows 7 to the instructions for accessing the Device Manager. 

 
In Windows Vista or Windows 7, use the following path to access the Device Manager: 

 
Start > Control Panel > System and Security > System > Device Manger 

 

 
 

 
 
 
 
 
 

 
 



 

IT Essentials v4.1 LI 5.4.6 Describe custom installation options 
 

CompTIA A+ 220-701 Objective 
3.3 Network Installation 
3.3 Recover CD 

 
To install Windows 7 over a network: 

 
1.   Prepare the computer by creating a FAT or FAT32 partition of at least 5 GB. You must make the 

partition bootable and include a network client. You can also use a boot disk that contains a 
network client so that the computer can connect to a file server over the network. 

2.   Copy the Windows 7 installation media to the network server and make sure to share the 
directory so that clients can connect and use the files. 

3.   Boot the computer and connect to the shared directory. 
4.   From the shared directory, run the setup program, setup.exe, located in the sources directory. 

The setup program copies all the installation files to your hard drive. After the installation files 
have been copied, the installation continues similar to installing from a disc. 

 
 

In Windows 7, you can use a system recovery disc to boot the computer and then use system recovery 
tools to recover Windows 7 from errors that prevent system startup. You can also use a system recovery 
disc to boot the computer and restore the entire computer from a system image. 

 
To create a Windows 7 system recovery disc, follow these steps: 

 
1.   Click Start > Control Panel > System and Security > Backup and Restore > Create a system 

repair disc. 
2.   Insert a blank disc in the optical disc drive and click Create Disc. 

3.   Test the disc by using it to boot the computer. 
4.   After the System Recovery Options screen is displayed, highlight the operating system that needs 

to be restored and click Next. The following tools should be available: 

 
• Startup Repair 

• System Restore 

• System Image Recovery 

• Windows Memory Diagnostic 

• Command Prompt 

 

IT Essentials v4.1 LI 5.4.9 Describe directory structures 
 

CompTIA A+ 220-701 Objective 
3.3 FAT32 vs. NTFS 

 
Windows XP and Windows 2000 support the FAT32 and NTFS file systems, while Windows Vista and 
Windows 7 use only NTFS. Security is one of the most important differences between FAT32 and NTFS. 
NTFS can support more files and larger files than FAT32, and it provides more flexible security features 
for files and folders. Figures 2 and 3 show the file permission properties for FAT32 and NTFS. 

 

 
In Windows 7, use this path: 

 
Start > Control Panel > Appearance and Personalization > Folder Options > View > Show hidden 
files and folders 

 
 
 
 
 



 
 
 
 
IT Essentials v4.1 LI 5.5.1 Manipulate items on the desktop 

 

CompTIA A+ 220-701 Objective 
3.1 Side bar, Aero, UAC, minimum system requirements, system limits 
3.1 User interface, start bar layout 
3.2 Libraries in Windows 7 
3.2 My Computer 
3.2 My Network Places / Home Group 
3.2 Start Menu 

 

Windows 7 Changes: Replace the entire page with the following text. 

 
After the operating system has been installed, the desktop can be customized to suit individual needs. A 
desktop on a computer is a graphical representation of a workspace. The desktop has icons, toolbars, 
and menus to manipulate files. The desktop can be customized with images, sounds, and colors to 
provide a more personalized look and feel. All of these customizable items together make up a theme. 
Windows Vista and Windows 7 have a special theme called Aero, as shown in Figure 1. Aero is the 
default theme and has translucent window borders, numerous animations, and live icons that are 
thumbnail images of the contents of a file. Because of the advanced graphics needed, the Aero theme 
can only be used on computers that meet the following hardware requirements: 

 
• 1 GHz 32-bit or 64-bit processor 

• 1 GB of RAM 

• 128 MB graphics card 

• DirectX 9 class graphics processor that supports a Windows Display Driver Model Driver, Pixel 
Shader 2.0 in hardware, and 32 bits per pixel. 

 
NOTE: Windows Vista Home Basic and Windows 7 Starter do not include the Aero theme. 

Windows 7 includes the following new Aero features: 

• Shake – Minimize all windows not being used by clicking a window and shaking the mouse. To 

maximize the windows again, click the same window and shake the mouse. 

• Peek – View the icons and gadgets on the desktop by pointing the mouse at the right edge of the 
taskbar to make all windows transparent. 

• Snap – Resize a window by dragging it to one of the edges of the screen. 

o Left – Fits the window to the left half of the screen 
o Right – Fits the window to the right half of the screen 
o Top – Maximizes the window to fill the entire screen 

 
In Windows Vista, a feature called the Sidebar, as shown in Figure 2, can also be personalized. The 
Sidebar is a graphical pane on the desktop that keeps gadgets organized. Gadgets are small applications 
such as games, sticky notes, or a clock. New gadgets, such as interfaces to web information, weather 
maps, or contacts on a social networking site can also be added to the Sidebar. 

 
In Windows 7, you can place gadgets anywhere on the desktop. You can choose to have gadgets snap or 
position themselves to the sides and corners of the desktop, as well as align to the other gadgets. 

 

 



 

 
 

 
To add gadgets to the desktop: 

 
1.   Right-click anywhere on the desktop and choose Gadgets. 

2.   Do any of the following: 

• Drag and drop the gadget from the menu to the desktop. 

• Double-click the gadget to add it to the desktop. 

• Right-click the gadget and choose Add. 

3.   To snap a gadget, drag it to the desired desktop location. The gadget aligns itself with the screen 
edges and other gadgets. 

 
Desktop Properties 
To customize the Windows XP GUI of your desktop, right-click the desktop and choose Properties. The 
Display Properties window, as shown in Figure 3, has five tabs: Themes, Desktop, Screen Saver, 
Appearance, and Settings. Click any of these tabs to customize your display settings. In Windows Vista 
and Windows 7, right-click the desktop and choose Personalize. The Personalization window in Windows 
Vista, as shown in Figure 4, has seven links: Window Color and Appearance, Desktop Background, 
Screen Saver, Sounds, Mouse Pointers, Themes, and Display Settings. Click any of these links to 
customize your display settings. In Windows 7, the Personalization window has three links on the left to 
change desktop icons, mouse pointers, and your account picture. Themes are chosen from the right 
panel. You can modify a theme’s background, color, sound, and screen saver using the four items under 
the window. 

 
Desktop Items 

There are several items on the desktop that can be customized, such as the Taskbar and Recycle Bin. To 
customize any item, right-click the item and then choose Properties. 

 
Start Menu 
On the desktop, the Start menu is accessed by clicking Start. The Start menu, shown in Figure 5, 
displays all of the applications installed in the computer, a list of recently opened documents, and a listing 
of other elements, such as a search feature, help center, and system settings. The Start menu can also 
be customized. There are two styles of Start menu: XP and Classic. The XP-style Start menu is used 
throughout this course for demonstrating command sequences. 

 
In Windows 7, the start menu styles have been removed. You may customize many different aspects of 
the start menu by using the customize start menu settings, as shown in Figure 6. To access the 
customize start menu settings, use the following path: 

 
Right-click an empty section of the taskbar and choose Properties > Start Menu > Customize. 

 
Taskbar 

In Windows 7, the following new features have been added to the taskbar to make navigating, organizing, 
and accessing windows and notifications easier: 

 
• Jump list – To display a list of tasks that are unique to the application, right-click its icon in the 

taskbar. 

• Pinned applications – To add an application to the taskbar for easy access, right-click the icon 
of an application and select Pin to taskbar. 

• Thumbnail previews – To view a thumbnail image of the window, hover the mouse over a 
taskbar icon. 

 
My Computer 
To access the various drives installed in the computer, double-click the My Computer icon that appears 
on the desktop. To customize certain settings, right-click My Computer and choose Properties. Settings 
that can be customized include the following: 

 



 

 
 

 
• Computer name 

• Hardware settings 

• Virtual memory 

• Automatic updates 

• Remote access 

 
NOTE: In Windows Vista and Windows 7, My Computer is called Computer. To customize certain 
settings, click Start then right-click Computer and choose Properties. In Windows 7, you must also click 
Advanced system settings. Access installed drives in Windows Vista and Windows 7 with the following 
path: 

 
Click Start > Computer 

 
Windows Explorer 

Windows 7 adds the following features to Windows Explorer: 

 
• Search box – Access previous searches. You can also filter search results. 

• New folder button – Create new folders with one click. 

• Arrange by – Organize items easily according to different criteria. 

• Preview pane button – Turn the preview pane on or off as needed. 

 
Windows 7 Libraries 

Libraries is a new Windows 7 feature that allows you to easily organize content from various storage 
devices on your local computer and network, including removable media, without actually moving the 
files. A library is a virtual folder that presents content from different locations within the same view. You 
can search a library, and you can filter the content using criteria such as author, date modified, or tag. 

 
When Windows 7 is installed, each user has four default libraries: Documents, Music, Pictures, and 
Videos. To access a library, open any folder and click Libraries in the left column. To add a file or folder 
to a library, right-click it and select Include in library, and then choose which library to add the item. The 
file or folder will be available when you open that library. 

 
To create a new library, open a folder and use the following path: 

 
Libraries > New library 

 
To customize a library, right-click the library and click Properties. The Properties window allows you to 
add folders to the library by clicking Include a folder. You can also change the icon for the library and 
customize how items can be arranged in that library. 

 
Launching Applications 

You can launch applications in several ways: 

 
• Click an application on the Start menu. 

• Double-click the application shortcut icon on the desktop. 

• Double-click the application executable file in My Computer in Windows XP. 

• Double-click the application executable file in Computer in Windows Vista and Windows 7. 

• Launch the application from the Run window or command line. 

 
My Network Places 
To view and configure network connections, right-click the My Network Places icon on the desktop. In 
My Network Places, you can connect to or disconnect from a network drive. Click Properties to configure 

existing network connections, such as a wired or wireless LAN connection. 
 
 



 

 
 

 
NOTE: In Windows Vista and Windows 7, My Network Places is called Network. 

In Windows Vista, access network connections using the following path: 

Start > right-click Network > Properties 

 
In Windows 7, access network connections using the following path: 

Click Start > Computer > right-click Network > Properties 

New Figure 6 
 

Customize Start Menu 

 

 

 

IT Essentials v4.1 LI 5.5.2 Explore Control Panel applets 
 

CompTIA A+ 220-701 Objective 
3.2 Control Panel 

 
Use the following path in Windows 7: 

 

 



 

 
 

 
Start > Control Panel > Appearance and Personalization > Display > Change display settings > 
Advanced settings 

 
IT Essentials v4.1 LI 5.5.3 Explore administrative tools 

 

CompTIA A+ 220-701 Objective 
3.2 Administrative tools, Performance monitor, Event Viewer, Services, Computer Management 
3.2 MMC 
3.2 Task Manager 
3.3 Device Manager 

 

 
Computer Management 
The Computer Management console, shown in Figure 1, allows you to manage many aspects of both 
your computer and remote computers. The Computer Management console addresses three main areas 
of administration: System Tools, Storage, and Services and Applications. You must have administrative 
privileges to access the Computer Management console. To view the Computer Management console, 
use the following path: 

 
Start > Control Panel > Administrative Tools > Computer Management 

 
In Windows 7, use the following path: 

 
Start > Control Panel > System and Security > Administrative Tools > Computer Management 

 
To view the Computer Management console for a remote computer, right-click Computer Management 
(Local) in the console tree and click Connect to another computer…. In the Another computer: box, 
type the name of the computer or click Browse… to find a computer you want to manage. 

 
Device Manager 

The Device Manager, shown in Figure 2, allows you to view all of the settings for devices in the computer. 
A common task for technicians is to view the values assigned for the IRQ, I/O address, and the DMA 
setting for all of the devices in the computer. To view the system resources in the Device Manager, use 
the following path: 

 
Start > Control Panel > System > Hardware > Device Manager > View > Resources 

 
In Windows Vista, use the following path: 

 
Start > Control Panel > System > Device Manager > Continue > View > Resources 

 
In Windows 7, use the following path: 

 
Start > Control Panel > System and Security > System > Device Manager > View > Resources by 
Type (or Resources by connection) 

 
From the Device Manager, you can quickly view the properties of any device in the system by double- 
clicking the device name. You can view the version of the installed driver, view driver file details, update a 
driver, or even roll back or uninstall a device driver. You can compare the driver version listed here with 
the version available from the website of your device manufacturer. 

 

 
 
 



 

 
 

 
In addition to the Device Manager, Windows 7 has two new device-specific programs for viewing devices 
and their capabilities. One is a control panel called Devices and Printers, as shown in Figure 3. This 
control panel incorporates the Printers and Faxes control panel with a new feature that only displays the 
external devices connected to the computer. You can access device-specific features by right-clicking the 
device. 

 
The second new program used to access devices in Windows 7 is the Device Stage, as shown in Figure 
4. The Device Stage can be opened by clicking an icon in the taskbar that is displayed when a device is 
connected to the computer. The Device Stage allows easy access to common tasks for each connected 
device. For example, after connecting an MP3 device, the Device Stage might show synching options, 
new software updates, or access to your music libraries. 

 
Task Manager 
The Task Manager, shown in Figure 5, allows you to view all applications that are currently running and to 
close any applications that have stopped responding. The Task Manager allows you to monitor the 
performance of the CPU and virtual memory, view all processes that are currently running, and view 
information about the network connections. To view information in the Task Manager, use the following 
path: 

 
CTRL-ALT-DEL > Task Manager 

 
In Windows Vista or Windows 7, use the following path: 

 
CTRL-ALT-DEL > Start Task Manager 

 
Services 

Services are executable programs that require little or no user input. Services can be set to run 
automatically when Windows starts, or manually when required. The Services console, shown in Figure 6, 
allows you to manage all of the services on your computer and remote computers. You can start, stop, or 
disable services. You can also change how a service starts, or define actions for the computer to perform 
automatically when a service fails. You must have administrative privileges to access the Services 
console. To view the Services console, use the following path: 

 
Start > Control Panel > Administrative Tools > Services 

 
In Windows 7, use the following path: 

 
Start > Control Panel > System and Security > Administrative Tools > Services 

 
To view the Services console for a remote computer, right-click Services (Local) in the console tree and 
click Connect to another computer…. In the Another computer: box, type the name of the computer or 
click Browse… to find a computer you want to manage. 

 
Performance Monitor 

The Performance Monitor console, shown in Figure 7, has two distinct parts: the System Monitor and 
Performance Logs and Alerts. The System Monitor displays real-time information about the processors, 
disks, memory, and network usage for your computer. You can easily summarize these activities through 
histograms, graphs, and reports. 

 
Performance Logs and Alerts allow you to record the performance data and configure alerts. The alerts 
will notify you when a specified usage falls below or rises above a specified threshold. You can set alerts 
to create entries in the event log, send a network message, begin a performance log, run a specific 
program, or any combination of these. You must have administrative privileges to access the 

 
 
 



 

 

 
Performance Monitor console. To view the Performance Monitor console in Windows XP, use the 
following path: 

 
Start > Control Panel > Administrative Tools > Performance 

 
In Windows Vista, use the following path: 

 
Start > Control Panel > Administrative Tools > Reliability and Performance Monitor > Continue 

 
In Windows 7, use the following path: 

 
Start > Control Panel > System and Security > Administrative Tools > Performance Monitor 

 
In Windows 7, you can also create a Data Collector Set, which is a combination of performance counters, 
event trace data, and configuration information, to analyze how a task affects computer performance. A 
Data Collector Set can be used individually, combined with other Data Collector Sets, viewed in the 
Performance Monitor, or set to form an alert when certain criteria are met, like Performance Logs and 
Alerts in previous versions of Windows. Data Collector Sets can also be used and analyzed by third-party 
applications. 

 
Event Viewer 

The Event Viewer, shown in Figure 8, logs a history of events regarding applications, security, and the 
system. These log files are a valuable troubleshooting tool. To access the Event Viewer, use the following 
path: 

 
Start > Control Panel > Administrative Tools > Event Viewer 

 
In Windows Vista, use the following path: 

 
Start > Control Panel > Administrative Tools > Event Viewer > Continue 

 
In Windows 7, use the following path: 

 
Start > Control Panel > System and Security > Administrative Tools > Event Viewer 

 
MMC 

The Microsoft Management console (MMC), shown in Figure 9, allows you to organize management 
tools, called snap-ins, in one location for easy administration. Web page links, tasks, ActiveX controls, 
and folders can also be added to the MMC. After you have configured an MMC, save it to keep all the 
tools and links in that MMC. You can create as many customized MMCs as needed, each with a different 
name. This is useful when multiple administrators manage different aspects of the same computer. Each 
administrator can have an individualized MMC for monitoring and configuring computer settings. You 
must have administrative privileges to access the MMC. To view the MMC in Windows XP, use the 
following path: 

 
Start > Run > Type mmc and Press Enter 

 
In Windows Vista, use the following path: 

 
Start > Start Search > Type mmc and Press Enter 

 
In Windows 7, use the following path: 

 

Start > Search programs and files > Type mmc and Press Enter 

 
 
 
 
 



 
 
Remote Desktop 

The Remote Desktop allows one computer to remotely take control of another computer. Remote 
technicians can use this troubleshooting feature to repair and upgrade computers. For Windows XP, 
Remote Desktop is available on Windows XP Professional only. To access the Remote Desktop in 
Windows XP Professional, use the following path: 

 
Start > All Programs > Accessories > Communications > Remote Desktop Connection 

 
In Windows Vista or Windows 7, use the following path: 

 
Start > All Programs > Accessories > Remote Desktop Connection 

 
Performance Settings 

To enhance the performance of the operating system, you can change some of the settings that your 
computer uses, such as virtual memory configuration settings, which are shown in Figure 10. To change 
the virtual memory setting in Windows XP, use the following path: 

 
Start > Control Panel > System > Advanced > Performance area > Settings button > Advanced tab > 
Change 

 
In Windows Vista, use the following path: 

 
Start > Control Panel > System > Advanced system settings > Continue > Advanced tab > 
Performance area > Settings button > Advanced > Change 

 
In Windows 7, use the following path: 

 
Start > Control Panel > System and Security > System > Advanced system settings > Performance 
> Settings button > Advanced > Change 

 
Renumber existing Figures 3-8 as Figures 5-10. 

 
New Figure 3 

 
Devices and Printers 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 
 

 
 

 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

New Figure 4 

 
Device Stage 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 

 
 

 

IT Essentials v4.1 LI 5.5.4 Install, navigate, and uninstall an application 
 

CompTIA A+ 220-701 Objective 
2.2 Application install 

 

 
In Windows 7, use the following path: 

 
Start > Control Panel > Programs > Programs and Features 

 
IT Essentials v4.1 LI 5.5.5 Describe upgrading an operating system 

 
CompTIA A+ 220-701 Objective 
3.1 Windows 2000 and newer – upgrade paths and requirements 

 

 
Upgrading the Operating System to Windows 7 

 
1.   Insert the Windows 7 media into the optical drive. The Set Up window appears. 
2.   You are presented with two options: Check compatibility online and Install now. 
3.   Select Install now. 

4.   You are prompted to download any important updates for installation. 
5.   Agree to the End User License Agreement (EULA), and click Next. 
6.   You are presented with two choices, Upgrade or Custom. 
7.   Click Upgrade. The system begins copying installation files. 

8.   Follow the prompts to complete the upgrade. When the install is complete, the computer will 
restart. 

 
Windows OS Upgrade Advisor 

 
Use the Windows 7 Upgrade Advisor to determine whether your PC can properly run Windows 7. As 
shown in Figure 2, the tool scans the hardware and programs for compatibility problems and then guides 
you through steps to resolve problems before upgrading to Windows 7. 

 
To use the Windows 7 Upgrade Advisor follow these steps: 

 
1.   Download and run the Windows 7 Upgrade Advisor from the Microsoft website. 
2.   Click Start check. The program scans your computer hardware, devices, and installed software. 

The computer displays a compatibility report that you can print or save. 
3.   Examine the report. Record any recommended fixes for the issues that are found. 
4.   Click Save Report if you want to keep it or print it later. 
5.   Click Close. 

 
NOTE: After making the recommended changes to hardware, devices, or software, Microsoft 

recommends running the Windows 7 Upgrade Advisor again. 

 
Microsoft Assessment and Planning Toolkit 

 

 
 
 
 



 

 
 

 
The Microsoft Assessment and Planning (MAP) toolkit software assesses computers to determine 
whether they can be migrated to Windows 7. The toolkit software is installed on only one computer. It 
collects information from computers on the network, such as an inventory of computers, applications, and 
devices. The MAP toolkit generates proposals and detailed reports about hardware, software, and device 
compatibility. 

 
Modified Figure 1 

 
OS can 
upgrade to: 

Windows NT Windows 2000 Windows XP Windows Vista Windows 7 

Windows 98 X √ √ √ X 
Windows NT N/A √ √ √ X 
Windows 2000 N/A N/A √ √ X 
Windows XP N/A N/A N/A √ X 
Windows Vista N/A N/A N/A N/A √ 

 
New Figure 2 

 
Windows 7 Upgrade Advisor Report 
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3.4 Boot to restore point 

 
 

In Windows 7, if the operating system fails to start, run the Restore Point utility from your installation disc 
by following these steps: 

 

1.   Insert the Windows 7 installation media. 
2.   Start the computer, and press any key to boot from the CD or DVD when prompted. 
3.   At the Install Windows screen, click Next. 
4.   Click Repair your computer. 
5.   Choose Use recovery tools that can help fix problems starting Windows. 
6.   Select the operating system that you want to repair and click Next. 
7.   Click System Restore. 

8.   Follow the prompts to restore your computer to an earlier state. 
 
 

In Windows 7, if your computer fails to boot, you can use a System Repair Disc to start the computer and 
access system recovery options if you do not have the original Windows 7 installation media, as shown in 
Figure 4. 

 

To create a System Repair Disc: 
 

1.   Click Start > Control Panel > System and Security > Backup and Restore > Create a system 
repair disc. 

2.   Insert a blank CD or DVD into the optical drive and click Create disc. 
 

New Figure 4 
 

System Recovery Options 
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2.5 Backup procedures 

 

 
To access the daily backup utility in Windows 7, use the following path: 

 
Start > Control Panel > System and Security > Backup and Restore 

 


